# CVE-2026-6475: PostgreSQL pg_basebackup and pg_rewind can overwrite unrelated files of origin superuser choice

> An origin superuser can overwrite local files via symlink following in pg_basebackup or pg_rewind, potentially hijacking the OS account.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 May 2026
- **Also known as:** ALPINE-CVE-2026-6475, AZL-86828, BELL-CVE-2026-6475, BIT-postgresql-2026-6475, CLSA-2026-1788193166, DEBIAN-CVE-2026-6475, ECHO-848c-5472-d56d, GHSA-7h2q-899j-9636, JLSEC-2026-603, MINI-3r2q-5c95-rhc7, MINI-958x-fmvr-62x6, MINI-9vwq-hh9w-r747, MINI-cxvx-g5cx-9pv7, MINI-mggv-f2q2-q5mw, MINI-xrgc-48fx-wh2f, UBUNTU-CVE-2026-6475

## What is CVE-2026-6475?

CVE-2026-6475 is a high-severity path traversal vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Symlink following in PostgreSQL pg_basebackup plain format and in pg_rewind allows an origin superuser to overwrite local files, e.g. /var/lib/postgres/.bashrc, that hijack the operating system account.  It will remain the case that starting the server after these commands implicitly trusts the origin superuser, due to features like shared_preload_libraries.  Hence, the attack has practical implications only if one takes relevant action between these commands and server start, like moving the files to a different VM or snapshotting the VM.  Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2026-6475?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6475?

Upgrade postgresql to a fixed version for your release line: 14.23.0, 15.18.0, 16.14.0 or 17.10.0.

## Is CVE-2026-6475 being exploited?

There is no known exploitation of CVE-2026-6475 in the wild and no public exploit code.

Public exploit code:

- PostgreSQL 18.6 - High - Remote - File write - pg_basebackup follows absolute tar symlink leftover of CVE-2026-6475 (github_poc): https://github.com/abraxas/postgres-basebackup-symlink

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6475 and fix it if it is affected.

What it is: CVE-2026-6475 is a high-severity path traversal vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-6475 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6475/ (Markdown: https://insights.sbomify.com/CVE-2026-6475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6475
- OSV: https://osv.dev/vulnerability/CVE-2026-6475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6475/
Summaries are generated and may contain mistakes; the official description above is the record.
