CVE-2026-6476 PostgreSQL pg_createsubscriber allows SQL injection via subscription name

High 7.2 Published Updated

An attacker with subscription rights can inject SQL into pg_createsubscriber to execute arbitrary commands as a superuser.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-6476?

CVE-2026-6476 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

SQL injection in PostgreSQL pg_createsubscriber allows an attacker with pg_create_subscription rights to execute arbitrary SQL as a superuser. The attack takes effect when pg_createsubscriber next runs. Within major versions 17 and 18, minor versions before PostgreSQL 18.4 and 17.10 are affected. Versions before PostgreSQL 17 are unaffected.

Weakness: CWE-89

Which versions are affected by CVE-2026-6476?

1 open source package ship an affected version, including postgresql. It affects 1 product.

PackageAffectedFixed in
postgresql BitnamiFrom 17.0.017.10.0, 18.4.0

Products include Postgresql Postgresql.

How do I fix CVE-2026-6476?

Upgrade postgresql to a fixed version for your release line: 17.10.0 or 18.4.0.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-6476 being exploited?

There is no known exploitation of CVE-2026-6476 in the wild and no public exploit code.

All Postgresql Postgresql vulnerabilities

Sources

Also known as ALPINE-CVE-2026-6476, BELL-CVE-2026-6476, BIT-postgresql-2026-6476, DEBIAN-CVE-2026-6476, ECHO-b729-aa9a-e866, GHSA-9crw-q654-rwgr and 3 more.

Is CVE-2026-6476 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free