{"answers":{"affected":"1 open source package ship an affected version, including postgresql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-6476 in the wild and no public exploit code.","fix":"Upgrade postgresql to a fixed version for your release line: 17.10.0 or 18.4.0.","what":"CVE-2026-6476 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6476 and fix it if it is affected.\n\nWhat it is: CVE-2026-6476 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6476 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- postgresql (Bitnami): affected from 17.0.0; fixed in 17.10.0, 18.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6476/ (Markdown: https://insights.sbomify.com/CVE-2026-6476/index.md)","id":"CVE-2026-6476","markdown":"https://insights.sbomify.com/CVE-2026-6476/index.md","name":"CVE-2026-6476","record":{"aliases":["ALPINE-CVE-2026-6476","BELL-CVE-2026-6476","BIT-postgresql-2026-6476","DEBIAN-CVE-2026-6476","ECHO-b729-aa9a-e866","GHSA-9crw-q654-rwgr","MINI-32cp-4qgq-hcvc","MINI-5cvf-7r22-48vp","UBUNTU-CVE-2026-6476"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL database","requires_auth":"high_privilege","summary":"An attacker with subscription rights can inject SQL into pg_createsubscriber to execute arbitrary commands as a superuser.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PostgreSQL","cpe":[{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"SQL injection in PostgreSQL pg_createsubscriber allows an attacker with pg_create_subscription rights to execute arbitrary SQL as a superuser.  The attack takes effect when pg_createsubscriber next runs.  Within major versions 17 and 18, minor versions before PostgreSQL 18.4 and 17.10 are affected.  Versions before PostgreSQL 17 are unaffected.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PostgreSQL pg_createsubscriber allows SQL injection via subscription name","id":"CVE-2026-6476","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"postgresql:postgresql","products":["postgresql:postgresql"],"type":"sql_injection","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"PostgreSQL libpq lo_* functions let server superuser overwrite client stack memory","id":"CVE-2026-6477"},"packages":[{"ecosystem":"Bitnami","fixed":["17.10.0","18.4.0"],"introduced":["17.0.0","18.0.0"],"last_affected":[],"package":"postgresql","purl":"pkg:bitnami/postgresql","source":"BIT-postgresql-2026-6476"}],"prev":{"headline":"PostgreSQL pg_basebackup and pg_rewind can overwrite unrelated files of origin superuser choice","id":"CVE-2026-6475"},"products":["PostgreSQL"],"published":"2026-05-14","related":[{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1902","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Information disclosure in n/a","id":"CVE-2013-1903","kev_date_added":null,"published":"2013-04-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2007-3279","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2002-1399","kev_date_added":null,"published":"2003-01-08"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2016-3065","kev_date_added":null,"published":"2016-04-11"},{"cvss_score":9,"headline":"Code injection in n/a","id":"CVE-2007-3280","kev_date_added":null,"published":"2007-06-19"},{"cvss_score":8.8,"headline":"PostgreSQL tsvector and tsquery undersize allocations, via integer wraparound","id":"CVE-2026-14662","kev_date_added":null,"published":"2026-08-13"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["n/a"]},"summary":"An attacker with subscription rights can inject SQL into pg_createsubscriber to execute arbitrary commands as a superuser.","url":"https://insights.sbomify.com/CVE-2026-6476/"}