# CVE-2026-6476: PostgreSQL pg_createsubscriber allows SQL injection via subscription name

> An attacker with subscription rights can inject SQL into pg_createsubscriber to execute arbitrary commands as a superuser.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 May 2026
- **Also known as:** ALPINE-CVE-2026-6476, BELL-CVE-2026-6476, BIT-postgresql-2026-6476, DEBIAN-CVE-2026-6476, ECHO-b729-aa9a-e866, GHSA-9crw-q654-rwgr, MINI-32cp-4qgq-hcvc, MINI-5cvf-7r22-48vp, UBUNTU-CVE-2026-6476

## What is CVE-2026-6476?

CVE-2026-6476 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

SQL injection in PostgreSQL pg_createsubscriber allows an attacker with pg_create_subscription rights to execute arbitrary SQL as a superuser.  The attack takes effect when pg_createsubscriber next runs.  Within major versions 17 and 18, minor versions before PostgreSQL 18.4 and 17.10 are affected.  Versions before PostgreSQL 17 are unaffected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-6476?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 17.0.0 | 17.10.0, 18.4.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6476?

Upgrade postgresql to a fixed version for your release line: 17.10.0 or 18.4.0.

## Is CVE-2026-6476 being exploited?

There is no known exploitation of CVE-2026-6476 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6476 and fix it if it is affected.

What it is: CVE-2026-6476 is a high-severity SQL injection vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6476 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 17.0.0; fixed in 17.10.0, 18.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6476/ (Markdown: https://insights.sbomify.com/CVE-2026-6476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6476
- OSV: https://osv.dev/vulnerability/CVE-2026-6476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6476/
Summaries are generated and may contain mistakes; the official description above is the record.
