CVE-2026-6479 PostgreSQL SSL/GSS init causes denial of service, via uncontrolled recursion
An attacker with socket access can cause sustained denial of service in PostgreSQL via uncontrolled recursion during SSL or GSS negotiation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-6479?
CVE-2026-6479 is a high-severity denial of service vulnerability in Postgresql Postgresql, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Uncontrolled recursion in PostgreSQL SSL and GSS negotiation allows an attacker able to connect to a PostgreSQL AF_UNIX socket to achieve sustained denial of service. If SSL and GSS are both disabled, an attacker can do the same via access to a PostgreSQL TCP socket. Versions before PostgreSQL 18.4, 17.10, 16.14, 15.18, and 14.23 are affected.
Weakness: CWE-674
Which versions are affected by CVE-2026-6479?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 14.23.0, 15.18.0, 16.14.0, 17.10.0, 18.4.0 |
Linux distribution packages (39)
pg_repack AlmaLinux:8 | All versions | 1.4.6-3.module_el8.9.0+3704+f1f917ce |
pgaudit AlmaLinux:8 | All versions | 1.4.0-7.module_el8.10.0+3889+48cb11fb.alma.1 |
pgaudit AlmaLinux:8 | All versions | 1.4.0-7.module_el8.9.0+3740+0e74851f.alma.1 |
postgres-decoderbufs AlmaLinux:8 | All versions | 0.10.0-2.module_el8.9.0+3704+f1f917ce |
postgresql AlmaLinux:8 | All versions | 12.22-9.module_el8.10.0+4249+5ffd6db7 |
postgresql-contrib AlmaLinux:8 | All versions | 12.22-9.module_el8.10.0+4249+5ffd6db7 |
postgresql-upgrade AlmaLinux:8 | All versions | 12.22-9.module_el8.10.0+4249+5ffd6db7 |
postgresql-upgrade-devel AlmaLinux:8 | All versions | 12.22-9.module_el8.10.0+4249+5ffd6db7 |
postgresql AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-contrib AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-docs AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-plperl AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-plpython3 AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-pltcl AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-private-devel AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-private-libs AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-server AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-server-devel AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-static AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-test AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-test-rpm-macros AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-upgrade AlmaLinux:9 | All versions | 13.23-5.el9_8 |
postgresql-upgrade-devel AlmaLinux:9 | All versions | 13.23-5.el9_8 |
pg_repack Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.6-3.module+el8.9.0+19330+c97ddbdf |
pg_repack-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.6-3.module+el8.9.0+19330+c97ddbdf |
pg_repack-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.6-3.module+el8.9.0+19330+c97ddbdf |
pgaudit Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.0-7.module+el8.10.0+22214+9beb89d6 |
pgaudit-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.0-7.module+el8.10.0+22214+9beb89d6 |
pgaudit-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:1.4.0-7.module+el8.10.0+22214+9beb89d6 |
postgres-decoderbufs Red Hat:enterprise_linux:8::appstream | All versions | 0:0.10.0-2.module+el8.9.0+19330+c97ddbdf |
postgres-decoderbufs-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:0.10.0-2.module+el8.9.0+19330+c97ddbdf |
postgres-decoderbufs-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:0.10.0-2.module+el8.9.0+19330+c97ddbdf |
postgresql Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-contrib Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-contrib-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-debugsource Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-docs Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
postgresql-docs-debuginfo Red Hat:enterprise_linux:8::appstream | All versions | 0:12.22-9.module+el8.10.0+24635+941a3cac |
Products include Postgresql Postgresql.
How do I fix CVE-2026-6479?
Upgrade postgresql to a fixed version for your release line: 14.23.0, 15.18.0, 16.14.0 or 17.10.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-6479 being exploited?
There is no known exploitation of CVE-2026-6479 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-6479, ALSA-2026:52395, ALSA-2026:52396, AZL-86843, BELL-CVE-2026-6479, BIT-postgresql-2026-6479 and 21 more.