# CVE-2026-64851: Grav Shortcode Core Plugin: Stored XSS in shortcode-core attribute handlers

> An attacker with admin.pages permission can inject stored XSS via shortcode attributes, executing scripts for visitors or administrators viewing the page.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-q5fw-vpqc-fgph

## What is CVE-2026-64851?

CVE-2026-64851 is a high-severity cross-site scripting vulnerability in getgrav grav-plugin-shortcode-core, published on 19 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Grav Shortcode Core Plugin allows for the development shortcode plugins that utilize the common format utilized by WordPress and BBCode. Prior to 6.2.2, Grav Shortcode Core passes shortcode syntax through Security::detectXss() because it contains no literal less-than character, then ColorShortcode.php and related attribute handlers concatenate an attacker-controlled parameter into HTML without encoding. An account with admin.pages permission can close the generated attribute and add an event handler, creating stored cross-site scripting that executes for visitors or administrators who view the page. This issue is fixed in version 6.2.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-64851?


## How do I fix CVE-2026-64851?

No fix has been published for CVE-2026-64851 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-64851 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-64851 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64851 and fix it if it is affected.

What it is: CVE-2026-64851 is a high-severity cross-site scripting vulnerability in getgrav grav-plugin-shortcode-core, published on 19 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-64851 exists.

Affected product: getgrav grav-plugin-shortcode-core. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64851/ (Markdown: https://insights.sbomify.com/CVE-2026-64851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64851
- OSV: https://osv.dev/vulnerability/CVE-2026-64851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64851/
Summaries are generated and may contain mistakes; the official description above is the record.
