# CVE-2026-64859: New API: User List API Leaks Root User Access Token Leading to Privilege Escalation

> An authenticated administrator can retrieve the root user's access token via the user list API, enabling privilege escalation to root-level system configuration access.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-6x2c-phff-wx57, GO-2026-6240

## What is CVE-2026-64859?

CVE-2026-64859 is a critical vulnerability in QuantumNous new-api, published on 17 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to 1.0.0-rc.7, the admin user list and user lookup APIs, including GET /api/user/, return User.AccessToken as access_token because User model objects are serialized after queries use Omit("password"), allowing an authenticated administrator to obtain the root user's bearer token and access root-only system configuration APIs. This issue is fixed in version 1.0.0-rc.7.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-64859?

3 open source packages ship an affected version, including github.com/QuantumNous/new-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/QuantumNous/new-api` | Go | All versions | 1.0.0-rc.7 |
| `github.com/QuantumNous/new-api` | Go | All versions | 1.0.0-rc.7 |
| `github.com/QuantumNous/new-api` | Go | All versions | 1.0.0-rc.7 |

## How do I fix CVE-2026-64859?

Upgrade github.com/QuantumNous/new-api to 1.0.0-rc.7 or later.

## Is CVE-2026-64859 being exploited?

There is no known exploitation of CVE-2026-64859 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-64859 and fix it if it is affected.

What it is: CVE-2026-64859 is a critical vulnerability in QuantumNous new-api, published on 17 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-64859 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 1.0.0-rc.7
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 1.0.0-rc.7
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 1.0.0-rc.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-64859/ (Markdown: https://insights.sbomify.com/CVE-2026-64859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-64859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-64859
- OSV: https://osv.dev/vulnerability/CVE-2026-64859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-64859/
Summaries are generated and may contain mistakes; the official description above is the record.
