# CVE-2026-6493: lukevella rallly Reset Password reset-password-form.tsx cross site scripting


- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 17 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** GHSA-cv47-g53v-q848

## What is CVE-2026-6493?

CVE-2026-6493 is a medium-severity vulnerability in lukevella rallly, published on 17 Apr 2026. 

### Official description

A flaw has been found in lukevella rallly up to 4.7.4. This affects an unknown function of the file apps/web/src/app/[locale]/(auth)/reset-password/components/reset-password-form.tsx of the component Reset Password Handler. Executing a manipulation of the argument redirectTo can lead to cross site scripting. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 4.8.0 mitigates this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-6493?


## How do I fix CVE-2026-6493?

No fix has been published for CVE-2026-6493 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-6493 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6493 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6493 and fix it if it is affected.

What it is: CVE-2026-6493 is a medium-severity vulnerability in lukevella rallly, published on 17 Apr 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6493 exists.

Affected product: lukevella rallly. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6493/ (Markdown: https://insights.sbomify.com/CVE-2026-6493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6493
- OSV: https://osv.dev/vulnerability/CVE-2026-6493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6493/
Summaries are generated and may contain mistakes; the official description above is the record.
