CVE-2026-65015 n8n before 2.30.1 Privilege Escalation via run_node_tool

High 7.2 Published Updated

A Project Viewer can escalate privileges and access secrets by exploiting missing authorization checks in the AI Agents node-execution tool.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-65015?

CVE-2026-65015 is a high-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n versions before 2.30.1 contain a privilege escalation vulnerability in the AI Agents feature where the node-execution tool lacks proper authorization checks. A Project Viewer user can escalate privileges by chatting with an agent that has node tools enabled, executing arbitrary nodes and accessing credential secrets without proper authorization verification.

Weakness: CWE-863

Which versions are affected by CVE-2026-65015?

4 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions2.29.8
n8n npmAll versions2.29.8
n8n npmFrom 2.30.02.30.1
n8n npmFrom 2.30.02.30.1

Products include N8n N8n.

How do I fix CVE-2026-65015?

Upgrade n8n to a fixed version for your release line: 2.29.8 or 2.30.1.

Is CVE-2026-65015 being exploited?

There is no known exploitation of CVE-2026-65015 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-x5vx-c2c8-m3w9, MINI-vj3f-rhm7-q3wq, ROOT-APP-NPM-CVE-2026-65015.

Is CVE-2026-65015 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free