CVE-2026-65016 n8n before 1.123.64, 2.29.8, and 2.30.1 Privilege Escalation via SSO Instance-Role
An SSO-authenticated user can escalate to instance owner if instance-role provisioning is enabled, gaining full administrative control over the n8n instance.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65016?
CVE-2026-65016 is a high-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a privilege escalation vulnerability in Enterprise SSO instance-role provisioning. The provisioning path maps an IdP-asserted role claim to an n8n global role but does not prevent assignment of the global:owner role (unlike the token-exchange identity path, which rejects it). An SSO-authenticated user whose instance-role claim resolves to global:owner is provisioned as instance owner, gaining full administrative control over workflows, credentials, users, and instance configuration. Exploitation requires that Enterprise SSO is configured, instance-role provisioning is enabled via N8N_SSO_SCOPES_PROVISION_INSTANCE_ROLE (disabled by default), and the attacker controls the instance-role claim value issued by the IdP.
Weakness: CWE-639
Which versions are affected by CVE-2026-65016?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.64 |
n8n npm | All versions | 1.123.64 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65016?
Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.
Is CVE-2026-65016 being exploited?
There is no known exploitation of CVE-2026-65016 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-35q8-9mj6-wjmf, MINI-h5cg-5ch4-mc3q, ROOT-APP-NPM-CVE-2026-65016.