# CVE-2026-65017: Apache Airflow: Config API: team-scoped Celery broker secret disclosed to a Viewer (multi-team masking bypass)

> Authenticated Viewers can read unmasked team-scoped Celery broker credentials in multi-team Apache Airflow deployments via the Config API.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-65017, GHSA-c56v-8w4g-3mfm, MINI-w5g2-pq48-c95r, PYSEC-2026-3993

## What is CVE-2026-65017?

CVE-2026-65017 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow's Config API did not mask team-scoped sensitive configuration values in multi-team deployments. When an administrator has enabled multi-team mode and exposed the Config API, an authenticated Viewer holding only configuration-read access — with no prior access to the secret — could read a team-scoped Celery broker URL, including its embedded credentials, in cleartext, while the equivalent global option was correctly masked. The secrets masker matched only base section and option names and did not normalize team-prefixed sections before the sensitivity check (CWE-200). This is a distinct masker bypass from CVE-2026-48828 and CVE-2026-48892: deployments that upgraded to apache-airflow 3.3.0 to address those issues remain affected by this team-scoped variant. Users are advised to upgrade to apache-airflow 3.3.1 or later, which normalizes team-scoped sections before masking.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-65017?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `apache-airflow` | PyPI | From 3.3.0 | 3.3.1 |
| `airflow` | Bitnami | From 3.3.0 | 3.3.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-65017?

Upgrade apache-airflow to 3.3.1 or later.

## Is CVE-2026-65017 being exploited?

There is no known exploitation of CVE-2026-65017 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65017 and fix it if it is affected.

What it is: CVE-2026-65017 is a medium-severity vulnerability in Apache Airflow, published on 12 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65017 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- apache-airflow (PyPI): affected from 3.3.0; fixed in 3.3.1
- airflow (Bitnami): affected from 3.3.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65017/ (Markdown: https://insights.sbomify.com/CVE-2026-65017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65017
- OSV: https://osv.dev/vulnerability/CVE-2026-65017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65017/
Summaries are generated and may contain mistakes; the official description above is the record.
