{"answers":{"affected":"5 open source packages ship an affected version, including aws-encryption-sdk.","exploited":"There is no known exploitation of CVE-2026-6550 in the wild and no public exploit code.","fix":"Upgrade aws-encryption-sdk to a fixed version for your release line: 3.3.1 or 4.0.5.","what":"CVE-2026-6550 is a medium-severity vulnerability in AWS Encryption SDK for Python, published on 20 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6550 and fix it if it is affected.\n\nWhat it is: CVE-2026-6550 is a medium-severity vulnerability in AWS Encryption SDK for Python, published on 20 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-6550 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-encryption-sdk (PyPI): affected from 2.0.0; fixed in 3.3.1, 4.0.5\n- aws-encryption-sdk (PyPI): affected from 2.0.0; fixed in 3.3.1\n- aws-encryption-sdk (PyPI): affected from 2.0.0; fixed in 3.3.1\n- aws-encryption-sdk (PyPI): affected from 4.0.0; fixed in 4.0.5\n- aws-encryption-sdk (PyPI): affected from 4.0.0; fixed in 4.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6550/ (Markdown: https://insights.sbomify.com/CVE-2026-6550/index.md)","id":"CVE-2026-6550","markdown":"https://insights.sbomify.com/CVE-2026-6550/index.md","name":"CVE-2026-6550","record":{"aliases":["GHSA-v638-38fc-rhfv","PYSEC-2026-2387"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"AWS Encryption SDK","requires_auth":"low_privilege","summary":"An authenticated local attacker can bypass key commitment policies via a shared key cache, allowing ciphertext to decrypt to multiple plaintexts.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-757","name":"Selection of Less-Secure Algorithm During Negotiation"}],"description":"Cryptographic algorithm downgrade in the caching layer of Amazon AWS Encryption SDK for Python before version 3.3.1 and before version  4.0.5 might allow an authenticated local threat actor to bypass key commitment policy enforcement via a shared key cache, resulting in ciphertext that can be decrypted to multiple different plaintexts.\n\nTo remediate this issue, users should upgrade to version 3.3.1, 4.0.5 or above.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Key commitment policy bypass via shared key cache in AWS Encryption SDK for Python","id":"CVE-2026-6550","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":5,"n_references":4,"next":{"headline":"Cross-site scripting in Timeline Blocks for Gutenberg","id":"CVE-2026-6551"},"packages":[{"ecosystem":"PyPI","fixed":["3.3.1","4.0.5"],"introduced":["2.0.0","4.0.0"],"last_affected":[],"package":"aws-encryption-sdk","purl":"pkg:pypi/aws-encryption-sdk","source":"PYSEC-2026-2387"},{"ecosystem":"PyPI","fixed":["3.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"aws-encryption-sdk","purl":null,"source":"GHSA-v638-38fc-rhfv"},{"ecosystem":"PyPI","fixed":["3.3.1"],"introduced":["2.0.0"],"last_affected":[],"package":"aws-encryption-sdk","purl":"pkg:pypi/aws-encryption-sdk","source":"GHSA-v638-38fc-rhfv"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"aws-encryption-sdk","purl":null,"source":"GHSA-v638-38fc-rhfv"},{"ecosystem":"PyPI","fixed":["4.0.5"],"introduced":["4.0.0"],"last_affected":[],"package":"aws-encryption-sdk","purl":"pkg:pypi/aws-encryption-sdk","source":"GHSA-v638-38fc-rhfv"}],"prev":{"headline":"Cross-site scripting in Logo Manager For Enamad","id":"CVE-2026-6549"},"products":["AWS Encryption SDK for Python"],"published":"2026-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["AWS"]},"summary":"An authenticated local attacker can bypass key commitment policies via a shared key cache, allowing ciphertext to decrypt to multiple plaintexts.","url":"https://insights.sbomify.com/CVE-2026-6550/"}