CVE-2026-65589 n8n before 1.123.64 Credential Exposure via LLM Node Execution Data

Medium 5.1 Published Updated

Authenticated users can read plaintext API keys and secrets from LLM node execution data due to improper masking of custom HTTP headers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-65589?

CVE-2026-65589 is a medium-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n versions before 1.123.64 fail to properly mask custom HTTP header credentials in LLM sub-node execution data, writing plaintext API keys and secrets to workflow execution records. Authenticated users with access to execution data can read exposed header values and credentials that persist in the database and can be exported.

Weakness: CWE-532

Which versions are affected by CVE-2026-65589?

6 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions1.123.64
n8n npmAll versions1.123.64
n8n npmFrom 2.0.0-rc.02.29.8
n8n npmFrom 2.0.0-rc.02.29.8
n8n npmFrom 2.30.02.30.1
n8n npmFrom 2.30.02.30.1

Products include N8n N8n.

How do I fix CVE-2026-65589?

Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.

Is CVE-2026-65589 being exploited?

There is no known exploitation of CVE-2026-65589 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-89gh-3pgc-v5h2, MINI-w5qh-65c6-vc3c.

Is CVE-2026-65589 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free