CVE-2026-65590 n8n before 2.30.1 Shell Sandbox Bypass on Linux Windows
Attackers can execute arbitrary shell commands on Linux and Windows hosts if the optional computer-use package is installed, bypassing intended sandbox restrictions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65590?
CVE-2026-65590 is a medium-severity command injection vulnerability in N8n N8n, published on 22 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
n8n before 2.29.8 and 2.30.x before 2.30.1 does not enforce shell sandbox restrictions on Linux and Windows in the @n8n/computer-use package (sandboxing was applied only on macOS). Shell commands executed by the tool run without any filesystem or network restrictions, allowing unrestricted access to the host filesystem and network from within the computer-use agent process. This issue only affects deployments where the @n8n/computer-use package is explicitly installed and running; standard n8n installations are not affected.
Weakness: CWE-78
Which versions are affected by CVE-2026-65590?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.29.8 |
n8n npm | All versions | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65590?
Upgrade n8n to a fixed version for your release line: 2.29.8 or 2.30.1.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-65590 being exploited?
There is no known exploitation of CVE-2026-65590 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-fpg6-x68q-5793, MINI-6hj7-9399-vv9p.