CVE-2026-65591 n8n before 1.123.64 Sanitizer Bypass Remote Code Execution
Authenticated users can bypass the sanitizer in the default legacy expression evaluator to achieve remote code execution on the host.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65591?
CVE-2026-65591 is a high-severity code injection vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.
Weakness: CWE-917
Which versions are affected by CVE-2026-65591?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.64 |
n8n npm | All versions | 1.123.64 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65591?
Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-65591 being exploited?
There is no known exploitation of CVE-2026-65591 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-pm35-fqvh-cq5g, MINI-4w9f-rg35-x6f9, ROOT-APP-NPM-CVE-2026-65591.