# CVE-2026-65591: n8n before 1.123.64 Sanitizer Bypass Remote Code Execution

> Authenticated users can bypass the sanitizer in the default legacy expression evaluator to achieve remote code execution on the host.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-pm35-fqvh-cq5g, MINI-4w9f-rg35-x6f9, ROOT-APP-NPM-CVE-2026-65591

## What is CVE-2026-65591?

CVE-2026-65591 is a high-severity code injection vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.

Weakness: CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-65591?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.64 |
| `n8n` | npm | All versions | 1.123.64 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.29.8 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.29.8 |
| `n8n` | npm | From 2.30.0 | 2.30.1 |
| `n8n` | npm | From 2.30.0 | 2.30.1 |

Products: N8n N8n.

## How do I fix CVE-2026-65591?

Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.

## Is CVE-2026-65591 being exploited?

There is no known exploitation of CVE-2026-65591 in the wild and no public exploit code.

Public exploit code:

- https://github.com/IamDremig/CVE-2026-65591 (github_poc): https://github.com/IamDremig/CVE-2026-65591

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65591 and fix it if it is affected.

What it is: CVE-2026-65591 is a high-severity code injection vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65591 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.64
- n8n (npm): affected all versions; fixed in 1.123.64
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.29.8
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.29.8
- n8n (npm): affected from 2.30.0; fixed in 2.30.1
- n8n (npm): affected from 2.30.0; fixed in 2.30.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65591/ (Markdown: https://insights.sbomify.com/CVE-2026-65591/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65591
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65591
- OSV: https://osv.dev/vulnerability/CVE-2026-65591

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65591/
Summaries are generated and may contain mistakes; the official description above is the record.
