CVE-2026-65592 n8n before 1.123.64 Stored DOM XSS via cachedResultUrl
An attacker with workflow editing privileges can inject malicious JavaScript via cachedResultUrl, leading to code execution in victims' browsers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-65592?
CVE-2026-65592 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n before 1.123.64, 2.29.8, and 2.30.1 contains a stored DOM cross-site scripting vulnerability in the Resource Locator component, which passes the workflow-persisted cachedResultUrl parameter to window.open() without scheme validation. An attacker with workflow creation/editing privileges can craft a workflow with a malicious (e.g., javascript:) scheme in cachedResultUrl; when a victim opens the crafted workflow and interacts with external links, the payload executes in the victim's browser.
Weakness: CWE-79
Which versions are affected by CVE-2026-65592?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.64 |
n8n npm | All versions | 1.123.64 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65592?
Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-65592 being exploited?
There is no known exploitation of CVE-2026-65592 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-9wcp-9r3j-383q, MINI-7j69-qq3f-7v6q, ROOT-APP-NPM-CVE-2026-65592.