CVE-2026-65593 n8n before 1.123.64, 2.29.8, and 2.30.1 SSRF via Dynamic Node Parameters

Medium 6.3 Published Updated

Authenticated attackers can bypass SSRF protections to make the n8n server issue requests to arbitrary internal targets when protection is disabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-65593?

CVE-2026-65593 is a medium-severity server-side request forgery vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n versions before 1.123.64, 2.29.8, and 2.30.1 contain a server-side request forgery vulnerability in the dynamic-node-parameters endpoints that lack authorization scopes. Authenticated attackers can supply absolute URLs in routing configuration to override baseURL restrictions and make the n8n server issue HTTP requests to arbitrary internal targets when SSRF protection is disabled.

Weakness: CWE-918

Which versions are affected by CVE-2026-65593?

6 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions1.123.64
n8n npmAll versions1.123.64
n8n npmFrom 2.0.0-rc.02.29.8
n8n npmFrom 2.0.0-rc.02.29.8
n8n npmFrom 2.30.02.30.1
n8n npmFrom 2.30.02.30.1

Products include N8n N8n.

How do I fix CVE-2026-65593?

Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2026-65593 being exploited?

There is no known exploitation of CVE-2026-65593 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-9w78-79q7-r4fp, MINI-q36g-jxgp-q5g6.

Is CVE-2026-65593 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free