CVE-2026-65594 n8n before 2.30.1 Missing OAuth Authorization Check
A member-level user can bypass authorization to access other users' workflows and credentials, leading to data exposure and privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65594?
CVE-2026-65594 is a medium-severity missing authorization vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 2.29.8 and 2.30.x before 2.30.1 (affected from 2.27.0, when the OAuth 2.1 consent and token-issuance flow was introduced) does not verify that the authenticated user has access to the workflow referenced as the OAuth resource. On instances with at least one active MCP Server Trigger workflow configured with n8n OAuth2 authentication, a member-level user can register an OAuth client, self-approve consent for another user's workflow, and obtain a valid token. The workflow then runs in the owner's project context with the owner's stored credentials, and the attacker can set tool inputs and read outputs (potentially including data from the owner's connected integrations), breaking user and project isolation.
Weakness: CWE-863
Which versions are affected by CVE-2026-65594?
4 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 2.29.8 |
n8n npm | All versions | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65594?
Upgrade n8n to a fixed version for your release line: 2.29.8 or 2.30.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-65594 being exploited?
There is no known exploitation of CVE-2026-65594 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-q5xf-xhwf-cwqf, MINI-xf7c-xvp6-jfc5.