CVE-2026-65595 n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token Exchange

High 8.9 Published Updated

Low-privileged users can escalate to admin via token exchange flaws in n8n, potentially achieving remote code execution if specific features are enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-65595?

CVE-2026-65595 is a high-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n before 2.30.1 and 2.29.8 assigns all Public API key scopes to JWTs issued through the Token Exchange module regardless of the acting user's role. On instances where the Token Exchange feature and Public API are enabled, a low-privileged user who can obtain a valid external JWT trusted by a configured issuer can use the resulting access token to invoke administrator-only Public API operations such as role escalation, user creation, and user deletion (role escalation requires an Advanced Permissions license), and, when unverified Community Package installation is enabled, achieve remote code execution.

Weakness: CWE-269

Which versions are affected by CVE-2026-65595?

4 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions2.29.8
n8n npmAll versions2.29.8
n8n npmFrom 2.30.02.30.1
n8n npmFrom 2.30.02.30.1

Products include N8n N8n.

How do I fix CVE-2026-65595?

Upgrade n8n to a fixed version for your release line: 2.29.8 or 2.30.1.

Is CVE-2026-65595 being exploited?

There is no known exploitation of CVE-2026-65595 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-777w-rpr6-c52h, MINI-44wf-vw37-xh27, ROOT-APP-NPM-CVE-2026-65595.

Is CVE-2026-65595 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free