{"answers":{"affected":"4 open source packages ship an affected version, including n8n. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-65595 in the wild and no public exploit code.","fix":"Upgrade n8n to a fixed version for your release line: 2.29.8 or 2.30.1.","what":"CVE-2026-65595 is a high-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65595 and fix it if it is affected.\n\nWhat it is: CVE-2026-65595 is a high-severity vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-65595 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- n8n (npm): affected all versions; fixed in 2.29.8\n- n8n (npm): affected all versions; fixed in 2.29.8\n- n8n (npm): affected from 2.30.0; fixed in 2.30.1\n- n8n (npm): affected from 2.30.0; fixed in 2.30.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65595/ (Markdown: https://insights.sbomify.com/CVE-2026-65595/index.md)","id":"CVE-2026-65595","markdown":"https://insights.sbomify.com/CVE-2026-65595/index.md","name":"CVE-2026-65595","record":{"aliases":["GHSA-777w-rpr6-c52h","MINI-44wf-vw37-xh27","ROOT-APP-NPM-CVE-2026-65595"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"n8n workflow automation","requires_auth":"low_privilege","summary":"Low-privileged users can escalate to admin via token exchange flaws in n8n, potentially achieving remote code execution if specific features are enabled.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"n8n","vendor":"n8n"}],"cvss":{"score":8.9,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"n8n before 2.30.1 and 2.29.8 assigns all Public API key scopes to JWTs issued through the Token Exchange module regardless of the acting user's role. On instances where the Token Exchange feature and Public API are enabled, a low-privileged user who can obtain a valid external JWT trusted by a configured issuer can use the resulting access token to invoke administrator-only Public API operations such as role escalation, user creation, and user deletion (role escalation requires an Advanced Permissions license), and, when unverified Community Package installation is enabled, achieve remote code execution.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"n8n before 2.29.8 and 2.30.1 Privilege Escalation via Token Exchange","id":"CVE-2026-65595","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"n8n:n8n","products":["n8n:n8n"],"type":"privilege_escalation","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"n8n before 1.123.64 Credential Exfiltration via GraphQL Node","id":"CVE-2026-65596"},"packages":[{"ecosystem":"npm","fixed":["2.29.8"],"introduced":["0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-777w-rpr6-c52h"},{"ecosystem":"npm","fixed":["2.29.8"],"introduced":["0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-777w-rpr6-c52h"},{"ecosystem":"npm","fixed":["2.30.1"],"introduced":["2.30.0"],"last_affected":[],"package":"n8n","purl":null,"source":"GHSA-777w-rpr6-c52h"},{"ecosystem":"npm","fixed":["2.30.1"],"introduced":["2.30.0"],"last_affected":[],"package":"n8n","purl":"pkg:npm/n8n","source":"GHSA-777w-rpr6-c52h"}],"prev":{"headline":"n8n before 2.30.1 Missing OAuth Authorization Check","id":"CVE-2026-65594"},"products":["n8n"],"published":"2026-07-22","related":[{"cvss_score":10,"headline":"n8n Improper Control of Dynamically-Managed Code Resources","id":"CVE-2025-68613","kev_date_added":"2026-03-11","published":"2025-12-19"},{"cvss_score":10,"headline":"n8n is vulnerable to Remote Code Execution via Arbitrary File Write","id":"CVE-2026-21877","kev_date_added":null,"published":"2026-01-08"},{"cvss_score":10,"headline":"n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling","id":"CVE-2026-21858","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":9.9,"headline":"n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution","id":"CVE-2026-1470","kev_date_added":null,"published":"2026-01-27"},{"cvss_score":9.9,"headline":"n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node","id":"CVE-2025-68668","kev_date_added":null,"published":"2025-12-26"},{"cvss_score":9.5,"headline":"n8n has Unauthenticated Expression Evaluation via Form Node","id":"CVE-2026-27493","kev_date_added":null,"published":"2026-02-25"},{"cvss_score":9.4,"headline":"n8n: HTTP Request Node Pagination Prototype Pollution to RCE","id":"CVE-2026-44789","kev_date_added":null,"published":"2026-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["n8n-io"]},"summary":"Low-privileged users can escalate to admin via token exchange flaws in n8n, potentially achieving remote code execution if specific features are enabled.","url":"https://insights.sbomify.com/CVE-2026-65595/"}