CVE-2026-65596 n8n before 1.123.64 Credential Exfiltration via GraphQL Node
Authenticated users can bypass domain restrictions in the GraphQL node to exfiltrate sensitive credentials from n8n instances.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65596?
CVE-2026-65596 is a medium-severity missing authorization vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n before 1.123.64, 2.29.8, and 2.30.1 fails to enforce the "Allowed HTTP Request Domains" restriction on HTTP-based credentials (Header Auth, Basic Auth, Query Auth, OAuth) in the GraphQL node, unlike the HTTP Request node. An authenticated user able to create or edit workflows can point the node's endpoint at a server they control and exfiltrate restricted credentials. Only instances where a credential has "Allowed HTTP Request Domains" configured and is usable by non-owner users are affected.
Weakness: CWE-863
Which versions are affected by CVE-2026-65596?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.64 |
n8n npm | All versions | 1.123.64 |
n8n npm | From 2.0.0 | 2.29.8 |
n8n npm | From 2.0.0 | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65596?
Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-65596 being exploited?
There is no known exploitation of CVE-2026-65596 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-gq66-9cw5-j5jm, MINI-rr79-q5pp-62x4.