CVE-2026-65597 n8n before 1.123.64 DOM-Based XSS via Unsandboxed iframe
An attacker with member privileges can execute arbitrary scripts in the victim's browser via unsandboxed HTML preview, potentially hijacking sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-65597?
CVE-2026-65597 is a high-severity cross-site scripting vulnerability in N8n N8n, published on 22 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n before 1.123.64, 2.x before 2.29.8, and before 2.30.1 contains a DOM-based cross-site scripting vulnerability in the HTML preview, which renders execution output into an iframe srcdoc without the sandbox attribute. A sanitizer bypass allows injected script to execute same-origin as the editor. When a victim opens the preview, the script can call authenticated APIs using the victim's session. An account with global:member privileges can exploit the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-65597?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.64 |
n8n npm | All versions | 1.123.64 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.0.0-rc.0 | 2.29.8 |
n8n npm | From 2.30.0 | 2.30.1 |
n8n npm | From 2.30.0 | 2.30.1 |
Products include N8n N8n.
How do I fix CVE-2026-65597?
Upgrade n8n to a fixed version for your release line: 1.123.64, 2.29.8 or 2.30.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-65597 being exploited?
There is no known exploitation of CVE-2026-65597 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-p3rg-hrf9-w9gj, MINI-2g7g-v6gp-88qm, ROOT-APP-NPM-CVE-2026-65597.