{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65603 exists.","fix":"No fix has been published for CVE-2026-65603 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-65603 is a high-severity vulnerability in getgrav grav, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65603 and fix it if it is affected.\n\nWhat it is: CVE-2026-65603 is a high-severity vulnerability in getgrav grav, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65603 exists.\n\nAffected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65603/ (Markdown: https://insights.sbomify.com/CVE-2026-65603/index.md)","id":"CVE-2026-65603","markdown":"https://insights.sbomify.com/CVE-2026-65603/index.md","name":"CVE-2026-65603","record":{"aliases":["GHSA-38mm-mxvc-j98q"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Grav Login Plugin","requires_auth":"low_privilege","summary":"Low-privilege users can escalate to super-admin via profile update if specific fields are enabled, leading to admin access and potential remote code execution.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"The Grav Login plugin (grav-plugin-login) versions \u003c= 3.8.11 contain a privilege escalation flaw in the authenticated profile self-update handler (processUserProfile(), the update_user task). Unlike the registration handler, this handler does not strip privilege fields ('groups','access') from user-submitted form data before persisting them. When an administrator has added 'groups' and/or 'access' to plugins.login.user_registration.fields and the default 'regular'/DataUser account backend is in use, a low-privilege authenticated user can POST crafted profile form data (e.g. access[admin][super]=true) to escalate to super-admin, enabling admin panel access, scheduler abuse (RCE), and Twig evaluation. Fixed in 3.8.12.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Grav Login Plugin 3.8.11 Privilege Escalation via Profile Update","id":"CVE-2026-65603","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Skipper Incomplete Fix for CVE-2026-50197 Policy Bypass","id":"CVE-2026-65604"},"packages":[],"prev":{"headline":"Traefik before 3.6.23 IngressRouteTCP ServersTransport Namespace Bypass","id":"CVE-2026-65602"},"products":["grav"],"published":"2026-07-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-22","vendors":["getgrav"]},"summary":"Low-privilege users can escalate to super-admin via profile update if specific fields are enabled, leading to admin access and potential remote code execution.","url":"https://insights.sbomify.com/CVE-2026-65603/"}