# CVE-2026-65603: Grav Login Plugin 3.8.11 Privilege Escalation via Profile Update

> Low-privilege users can escalate to super-admin via profile update if specific fields are enabled, leading to admin access and potential remote code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-38mm-mxvc-j98q

## What is CVE-2026-65603?

CVE-2026-65603 is a high-severity vulnerability in getgrav grav, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Grav Login plugin (grav-plugin-login) versions <= 3.8.11 contain a privilege escalation flaw in the authenticated profile self-update handler (processUserProfile(), the update_user task). Unlike the registration handler, this handler does not strip privilege fields ('groups','access') from user-submitted form data before persisting them. When an administrator has added 'groups' and/or 'access' to plugins.login.user_registration.fields and the default 'regular'/DataUser account backend is in use, a low-privilege authenticated user can POST crafted profile form data (e.g. access[admin][super]=true) to escalate to super-admin, enabling admin panel access, scheduler abuse (RCE), and Twig evaluation. Fixed in 3.8.12.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-65603?


## How do I fix CVE-2026-65603?

No fix has been published for CVE-2026-65603 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-65603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65603 and fix it if it is affected.

What it is: CVE-2026-65603 is a high-severity vulnerability in getgrav grav, published on 22 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65603 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65603/ (Markdown: https://insights.sbomify.com/CVE-2026-65603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65603
- OSV: https://osv.dev/vulnerability/CVE-2026-65603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65603/
Summaries are generated and may contain mistakes; the official description above is the record.
