{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65608 exists.","fix":"Upgrade getgrav/grav to 2.0.9 or later.","what":"CVE-2026-65608 is a high-severity code injection vulnerability in getgrav grav, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65608 and fix it if it is affected.\n\nWhat it is: CVE-2026-65608 is a high-severity code injection vulnerability in getgrav grav, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65608 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected from 1.7.0; fixed in 2.0.9\n- getgrav/grav (Packagist): affected from 1.7.0; fixed in 2.0.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65608/ (Markdown: https://insights.sbomify.com/CVE-2026-65608/index.md)","id":"CVE-2026-65608","markdown":"https://insights.sbomify.com/CVE-2026-65608/index.md","name":"CVE-2026-65608","record":{"aliases":["GHSA-c4wf-2xxc-68qm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Authenticated users with Flex directory permissions can execute arbitrary shell commands via unsafe dynamic data field resolution in Grav CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Grav versions \u003e= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Grav before 2.0.9 Remote Code Execution via FlexDirectory","id":"CVE-2026-65608","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Out-of-bounds write in nnn","id":"CVE-2026-65609"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.9"],"introduced":["1.7.0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-c4wf-2xxc-68qm"},{"ecosystem":"Packagist","fixed":["2.0.9"],"introduced":["1.7.0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-c4wf-2xxc-68qm"}],"prev":{"headline":"SiYuan before v3.7.2 Path Traversal via /export/temp/","id":"CVE-2026-65607"},"products":["grav"],"published":"2026-07-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Authenticated users with Flex directory permissions can execute arbitrary shell commands via unsafe dynamic data field resolution in Grav CMS.","url":"https://insights.sbomify.com/CVE-2026-65608/"}