# CVE-2026-65608: Grav before 2.0.9 Remote Code Execution via FlexDirectory

> Authenticated users with Flex directory permissions can execute arbitrary shell commands via unsafe dynamic data field resolution in Grav CMS.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-c4wf-2xxc-68qm

## What is CVE-2026-65608?

CVE-2026-65608 is a high-severity code injection vulnerability in getgrav grav, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav versions >= 1.7.0 and before 2.0.9 contain a remote code execution vulnerability. FlexDirectory::dynamicDataField() resolves blueprint data-*@: directives by calling call_user_func_array() on attacker-influenced input, validating only that the target is callable (is_callable()) without restricting dangerous functions such as exec, system, passthru, or shell_exec. Because FlexDirectory registers this handler for every Flex directory, it bypasses the validation added to Blueprint::dynamicData() in 2.0.7 (GHSA-fj2p-qj2f-74v5). Any authenticated user with create or update permission on any Flex-based directory (Flex Users, Flex Pages, Flex Objects, or custom Flex types) can execute arbitrary shell commands on the server.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-65608?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | From 1.7.0 | 2.0.9 |
| `getgrav/grav` | Packagist | From 1.7.0 | 2.0.9 |

## How do I fix CVE-2026-65608?

Upgrade getgrav/grav to 2.0.9 or later.

## Is CVE-2026-65608 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65608 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65608 and fix it if it is affected.

What it is: CVE-2026-65608 is a high-severity code injection vulnerability in getgrav grav, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65608 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected from 1.7.0; fixed in 2.0.9
- getgrav/grav (Packagist): affected from 1.7.0; fixed in 2.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65608/ (Markdown: https://insights.sbomify.com/CVE-2026-65608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65608
- OSV: https://osv.dev/vulnerability/CVE-2026-65608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65608/
Summaries are generated and may contain mistakes; the official description above is the record.
