# CVE-2026-65633: Purpose-limited JWT accepted as full bearer authentication in AshAuthentication

> Attackers can use single-purpose sign-in JWTs as full bearer tokens to bypass authentication and take over user accounts in AshAuthentication.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** EEF-CVE-2026-65633, GHSA-6vcj-3h59-rrc3

## What is CVE-2026-65633?

CVE-2026-65633 is a high-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Authentication vulnerability in team-alembic AshAuthentication allows purpose-limited JWTs to be replayed as full bearer API credentials when a resource uses stateless bearer-token verification.

The bearer-token authentication helper AshAuthentication.Plug.Helpers.retrieve_from_bearer/3 verifies an Authorization: Bearer JWT's signature and rejects tokens containing an act claim, but performs no check that the token's purpose claim equals user at the bearer boundary. When the resource is configured with require_token_presence_for_authentication?: false (the DSL default), the follow-on validate_token/3 helper returns {:ok, nil} without consulting the token resource, so no downstream check on purpose takes place either. As a result, any valid, non-expired JWT the library itself issued for a narrow, single-purpose flow (most notably the purpose: sign_in token that WebAuthn always emits during sign-in, and that the Password strategy emits when sign-in tokens are enabled) is accepted directly as a general-purpose bearer credential and resolves to a full current_user assignment.

This bypasses the library's intended token-exchange contract, in which the sign_in token is meant to be presented exactly once to a preparation that validates the purpose claim and immediately revokes the token. The first use of a still-valid sign-in token presented directly in the Authorization header succeeds because the stateless bearer path never scopes it to purpose == "user".

An attacker who obtains a not-yet-exchanged sign-in token for a target subject (for example via log or referrer leakage, an intercepted magic-link delivery channel, or a partially compromised intermediary) can present it as a bearer token and be authenticated as that subject, fully bypassing the intended one-time-use and revocation semantics. Exploitation additionally requires that the host application wire up retrieve_from_bearer/3 on a reachable route and uses either WebAuthn (sign-in tokens are always issued) or the Password strategy with sign_in_tokens_enabled?: true. Resources configured with require_token_presence_for_authentication?: true (including applications scaffolded by the Igniter installer since v4.5.0) and the session-based path (authenticate_resource_from_session/4) enforce purpose == "user" against the stored token record and are not affected.

This issue affects ash_authentication: from 3.10.5 before 4.14.2 and from 5.0.0-rc.0 before 5.0.0-rc.13.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-65633?

1 open source package ship an affected version, including ash_authentication.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_authentication` | Hex | From 3.10.5 | 4.14.2, 5.0.0-rc.13 |

## How do I fix CVE-2026-65633?

Upgrade ash_authentication to a fixed version for your release line: 4.14.2 or 5.0.0-rc.13.

## Is CVE-2026-65633 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65633 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65633 and fix it if it is affected.

What it is: CVE-2026-65633 is a high-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65633 exists.

Affected packages and fixed versions:
- ash_authentication (Hex): affected from 3.10.5; fixed in 4.14.2, 5.0.0-rc.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65633/ (Markdown: https://insights.sbomify.com/CVE-2026-65633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65633
- OSV: https://osv.dev/vulnerability/CVE-2026-65633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65633/
Summaries are generated and may contain mistakes; the official description above is the record.
