{"answers":{"affected":"1 open source package ship an affected version, including ymlr.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65636 exists.","fix":"Upgrade ymlr to 5.1.6 or later.","what":"CVE-2026-65636 is a low-severity code injection vulnerability in ufirstgroup ymlr, published on 31 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65636 and fix it if it is affected.\n\nWhat it is: CVE-2026-65636 is a low-severity code injection vulnerability in ufirstgroup ymlr, published on 31 Jul 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65636 exists.\n\nAffected packages and fixed versions:\n- ymlr (Hex): affected from 0.0.1; fixed in 5.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65636/ (Markdown: https://insights.sbomify.com/CVE-2026-65636/index.md)","id":"CVE-2026-65636","markdown":"https://insights.sbomify.com/CVE-2026-65636/index.md","name":"CVE-2026-65636","record":{"aliases":["EEF-CVE-2026-65636","GHSA-p8qx-7cp9-v6c9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Elixir YAML library","requires_auth":"none","summary":"Attackers can inject arbitrary YAML content via unescaped newlines in comments, potentially altering configuration or triggering code execution in downstream consumers.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"EEF","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-93","name":"Improper Neutralization of CRLF Sequences"}],"description":"Improper Neutralization of CRLF Sequences vulnerability in ufirstgroup ymlr (Elixir.Ymlr module) allows attackers to inject arbitrary content into generated YAML documents through document comments. Ymlr.document!/2 interpolates each caller-supplied comment string into the output behind a single # prefix without validating it or escaping line breaks. Because a YAML comment is terminated by a line break, the first carriage return or line feed in the comment string ends the comment context and everything after it is emitted at column 0 of the document body.\n\nAn attacker who controls text that the host application passes as a comment can forge top-level mapping keys, override values the application itself set, and emit --- or ... markers that split the output into additional documents. Downstream consumers of the generated YAML, such as configuration loaders, deployment manifests, CI pipelines and data importers, parse the injected content as legitimate data. The same clause backs Ymlr.document/2, Ymlr.documents!/2 and Ymlr.documents/2, so every document encoding entry point is affected.\n\nThis vulnerability is associated with program files lib/ymlr.ex and program routines 'Elixir.Ymlr':document!/2, 'Elixir.Ymlr':documents!/2.\n\nThis issue affects ymlr from 0.0.1 before 5.1.6.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YAML injection via unescaped newlines in ymlr document comments","id":"CVE-2026-65636","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":5,"next":{"headline":"Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete","id":"CVE-2026-65637"},"packages":[{"ecosystem":"Hex","fixed":["5.1.6"],"introduced":["0.0.1"],"last_affected":[],"package":"ymlr","purl":"pkg:hex/ymlr","source":"EEF-CVE-2026-65636"}],"prev":{"headline":"Boruta dynamic client registration allows creation of over-privileged OAuth clients","id":"CVE-2026-65635"},"products":["ymlr"],"published":"2026-07-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Erlang Ecosystem Foundation","prefix":"EEF"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-01","vendors":["ufirstgroup"]},"summary":"Attackers can inject arbitrary YAML content via unescaped newlines in comments, potentially altering configuration or triggering code execution in downstream consumers.","url":"https://insights.sbomify.com/CVE-2026-65636/"}