CVE-2026-65637 Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete
Attackers can bypass strict SNI validation in Apache Tomcat via HTTP/2 requests, potentially undermining TLS security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-65637?
CVE-2026-65637 is a critical vulnerability in Apache Tomcat, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.
This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.
Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
Weakness: CWE-20
Which versions are affected by CVE-2026-65637?
13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.53 | 10.1.59 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.53 | 10.1.59 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.20 | 11.0.25 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.20 | 11.0.25 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.115 | 9.0.121 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.115 | 9.0.121 |
7 more packages
tomcat Bitnami | From 9.0.115 | 9.0.121, 10.1.58, 11.0.25 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.53 | 10.1.59 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.53 | 10.1.59 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.20 | 11.0.25 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.20 | 11.0.25 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.115 | 9.0.121 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.115 | 9.0.121 |
Products include Apache Tomcat.
How do I fix CVE-2026-65637?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.59, 11.0.25 or 9.0.121.
Is CVE-2026-65637 being exploited?
There is no known exploitation of CVE-2026-65637 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-65637, DEBIAN-CVE-2026-65637, GHSA-f525-44xv-f2qj, MINI-3q2f-hhhj-hgmh, MINI-q9h5-f9vm-mv9x, MINI-vjj9-fvv5-7j54 and 2 more.