# CVE-2026-65637: Apache Tomcat: HTTP/2 no-authority bypass of strict SNI validation - CVE-2026-32990 fix incomplete

> Attackers can bypass strict SNI validation in Apache Tomcat via HTTP/2 requests, potentially undermining TLS security controls.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** BIT-tomcat-2026-65637, DEBIAN-CVE-2026-65637, GHSA-f525-44xv-f2qj, MINI-3q2f-hhhj-hgmh, MINI-q9h5-f9vm-mv9x, MINI-vjj9-fvv5-7j54, MINI-w4f2-3wv7-9jx6, UBUNTU-CVE-2026-65637

## What is CVE-2026-65637?

CVE-2026-65637 is a critical vulnerability in Apache Tomcat, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.

This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.

Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-65637?

13 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.53 | 10.1.59 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.53 | 10.1.59 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.20 | 11.0.25 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.20 | 11.0.25 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.115 | 9.0.121 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.115 | 9.0.121 |
| `tomcat` | Bitnami | From 9.0.115 | 9.0.121, 10.1.58, 11.0.25 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.53 | 10.1.59 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.53 | 10.1.59 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.20 | 11.0.25 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.20 | 11.0.25 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.115 | 9.0.121 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.115 | 9.0.121 |

Products: Apache Tomcat.

## How do I fix CVE-2026-65637?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.59, 11.0.25 or 9.0.121.

## Is CVE-2026-65637 being exploited?

There is no known exploitation of CVE-2026-65637 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65637 and fix it if it is affected.

What it is: CVE-2026-65637 is a critical vulnerability in Apache Tomcat, published on 25 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65637 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.53; fixed in 10.1.59
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.53; fixed in 10.1.59
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.20; fixed in 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.20; fixed in 11.0.25
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.115; fixed in 9.0.121
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.115; fixed in 9.0.121
- tomcat (Bitnami): affected from 9.0.115; fixed in 9.0.121, 10.1.58, 11.0.25
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.53; fixed in 10.1.59
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.53; fixed in 10.1.59
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.20; fixed in 11.0.25
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.20; fixed in 11.0.25
- org.apache.tomcat:tomcat-coyote (Maven): affected from 9.0.115; fixed in 9.0.121

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65637/ (Markdown: https://insights.sbomify.com/CVE-2026-65637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65637
- OSV: https://osv.dev/vulnerability/CVE-2026-65637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65637/
Summaries are generated and may contain mistakes; the official description above is the record.
