{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2026-65640 in the wild and no public exploit code.","fix":"Upgrade wordpress to 7.0.4 or later.","what":"CVE-2026-65640 is a high-severity vulnerability in WordPress, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65640 and fix it if it is affected.\n\nWhat it is: CVE-2026-65640 is a high-severity vulnerability in WordPress, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-65640 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 7.0.4\n- wordpress-multisite (Bitnami): affected all versions; fixed in 7.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65640/ (Markdown: https://insights.sbomify.com/CVE-2026-65640/index.md)","id":"CVE-2026-65640","markdown":"https://insights.sbomify.com/CVE-2026-65640/index.md","name":"CVE-2026-65640","record":{"aliases":["BIT-wordpress-2026-65640","BIT-wordpress-multisite-2026-65640","DEBIAN-CVE-2026-65640","MINI-vc9w-9j3w-97hh","UBUNTU-CVE-2026-65640"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"An attacker with upload privileges can achieve remote code execution by uploading a malicious Postscript file if Imagick and Ghostscript are enabled.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher.\n\nPrerequisites:\n* Imagick and Ghostscript in use on the server\n* A malicious user with the `upload_files` capability\n\nThis issue affects all versions of WordPress. Version 7.0.4 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-08-13","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-08-13T07:24:29Z","kind":"github_poc","ref":"https://github.com/jobusa755-a11y/CVE-2026-65640-","stars":0,"title":"WordPress Core \u003c= 7.0.3 - Authenticated (Author+) Remote Code Execution via Malicious File Upload"}],"tier":"poc_unverified"},"has_fix":true,"headline":"File upload in WordPress","id":"CVE-2026-65640","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Auth bypass in One","id":"CVE-2026-65641"},"packages":[{"ecosystem":"Bitnami","fixed":["7.0.4"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2026-65640"},{"ecosystem":"Bitnami","fixed":["7.0.4"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2026-65640"}],"prev":{"headline":"Command injection in ConfigServer Security \u0026 Firewall","id":"CVE-2026-65639"},"products":["WordPress"],"published":"2026-08-17","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["WordPress"]},"summary":"An attacker with upload privileges can achieve remote code execution by uploading a malicious Postscript file if Imagick and Ghostscript are enabled.","url":"https://insights.sbomify.com/CVE-2026-65640/"}