# CVE-2026-65640: File upload in WordPress

> An attacker with upload privileges can achieve remote code execution by uploading a malicious Postscript file if Imagick and Ghostscript are enabled.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** BIT-wordpress-2026-65640, BIT-wordpress-multisite-2026-65640, DEBIAN-CVE-2026-65640, MINI-vc9w-9j3w-97hh, UBUNTU-CVE-2026-65640

## What is CVE-2026-65640?

CVE-2026-65640 is a high-severity vulnerability in WordPress, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher.

Prerequisites:
* Imagick and Ghostscript in use on the server
* A malicious user with the `upload_files` capability

This issue affects all versions of WordPress. Version 7.0.4 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-65640?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 7.0.4 |
| `wordpress-multisite` | Bitnami | All versions | 7.0.4 |

## How do I fix CVE-2026-65640?

Upgrade wordpress to 7.0.4 or later.

## Is CVE-2026-65640 being exploited?

There is no known exploitation of CVE-2026-65640 in the wild and no public exploit code.

Public exploit code:

- WordPress Core <= 7.0.3 - Authenticated (Author+) Remote Code Execution via Malicious File Upload (github_poc): https://github.com/jobusa755-a11y/CVE-2026-65640-

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65640 and fix it if it is affected.

What it is: CVE-2026-65640 is a high-severity vulnerability in WordPress, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65640 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 7.0.4
- wordpress-multisite (Bitnami): affected all versions; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65640/ (Markdown: https://insights.sbomify.com/CVE-2026-65640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65640
- OSV: https://osv.dev/vulnerability/CVE-2026-65640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65640/
Summaries are generated and may contain mistakes; the official description above is the record.
