# CVE-2026-6567: Incorrect Authorization in GitLab

> Authenticated users with reporter role can access restricted CI artifact reports due to missing authorization checks in GitLab.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** BIT-gitlab-2026-6567, GHSA-h447-825w-w7xq, MINI-22x8-xxmw-cgmp, MINI-24pp-qxg8-gf6r, MINI-2mjf-mq3f-f45p, MINI-32jm-59hj-rr8m, MINI-3g68-g9h5-gqr7, MINI-3pwf-94h8-w6m5, MINI-47w2-8jg6-rrxj, MINI-4q3f-4xgf-rjv3, MINI-6jw4-6858-xpg7, MINI-753v-jjvv-9p36, MINI-7cfr-fmq7-3p82, MINI-7j6h-wc8j-9688, MINI-7qjq-rjqc-5rw5, MINI-844g-xm46-4rmf, MINI-8j7j-8fgp-rhmg, MINI-8px7-v7jj-jr5j, MINI-9vv8-37vq-cc6g, MINI-9xvq-vmwf-3x48, MINI-c4ww-77vc-42xp, MINI-cmvc-5rgp-2qv3, MINI-cpwp-3px5-v22v, MINI-fc6f-xv27-c9xw, MINI-fm84-gmr8-9q85, MINI-g2xx-4fp3-g975, MINI-g55g-qj47-qvrw, MINI-gpqj-468v-4r78, MINI-gxqx-wg86-7jv4, MINI-hfq5-j497-q559, MINI-hmjx-fc99-q5m4, MINI-jm8m-64fc-w464, MINI-m3rh-gw72-73xv, MINI-mpw3-vcq4-72p4, MINI-mvq7-294w-72qg, MINI-p7jw-4rhp-85cw, MINI-p96j-g7gm-j86g, MINI-ph85-g2jc-9wwr, MINI-phvf-6wxc-6w42, MINI-q4gp-mvxw-2jw3, MINI-qq8g-q3m3-9h67, MINI-qx6c-wr7w-x2fj, MINI-r78m-j3h6-qcww, MINI-r7v2-p2v5-774r, MINI-r929-p8g3-g8vx, MINI-v66x-q8j2-5r43, MINI-v7wg-fhxw-3r7f, MINI-w222-cj83-xvc8, MINI-w52f-7j9m-mwh6, MINI-w8ph-pgff-q7fv, MINI-w8xp-jvgq-rq6j, MINI-wc68-mwrx-rc2c, MINI-wqcv-8428-m8h4, UBUNTU-CVE-2026-6567

## What is CVE-2026-6567?

CVE-2026-6567 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 13.8 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user with reporter role to access restricted CI artifact report content they were not authorized to, due to missing authorization checks.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-6567?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 13.8.0 | 19.2.8, 19.3.5, 19.4.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-6567?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

## Is CVE-2026-6567 being exploited?

There is no known exploitation of CVE-2026-6567 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6567 and fix it if it is affected.

What it is: CVE-2026-6567 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-6567 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 13.8.0; fixed in 19.2.8, 19.3.5, 19.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6567/ (Markdown: https://insights.sbomify.com/CVE-2026-6567/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6567
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6567
- OSV: https://osv.dev/vulnerability/CVE-2026-6567

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6567/
Summaries are generated and may contain mistakes; the official description above is the record.
