CVE-2026-6575 PostgreSQL pg_restore_attribute_stats accepts values that cause query planning to read past end of stats array
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-6575?
CVE-2026-6575 is a medium-severity vulnerability in Postgresql Postgresql, published on 14 May 2026.
Official description
Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array. This allows a table maintainer to infer memory values past that array end. Within major version 18, minor versions before PostgreSQL 18.4 are affected. Versions before PostgreSQL 18 are unaffected.
Weakness: CWE-126
Which versions are affected by CVE-2026-6575?
1 open source package ship an affected version, including postgresql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | From 18.0.0 | 18.4.0 |
Products include Postgresql Postgresql.
How do I fix CVE-2026-6575?
Upgrade postgresql to 18.4.0 or later.
Is CVE-2026-6575 being exploited?
There is no known exploitation of CVE-2026-6575 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2026-6575, BELL-CVE-2026-6575, BIT-postgresql-2026-6575, DEBIAN-CVE-2026-6575, GHSA-f8xc-gmqx-v9fh, MINI-58x2-2hjp-qj87 and 1 more.