# CVE-2026-6575: PostgreSQL pg_restore_attribute_stats accepts values that cause query planning to read past end of stats array


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** ALPINE-CVE-2026-6575, BELL-CVE-2026-6575, BIT-postgresql-2026-6575, DEBIAN-CVE-2026-6575, GHSA-f8xc-gmqx-v9fh, MINI-58x2-2hjp-qj87, UBUNTU-CVE-2026-6575

## What is CVE-2026-6575?

CVE-2026-6575 is a medium-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. 

### Official description

Buffer over-read in PostgreSQL function pg_restore_attribute_stats() accepts array values of unmatched length, which causes query planning to read past end of one array.  This allows a table maintainer to infer memory values past that array end.  Within major version 18, minor versions before PostgreSQL 18.4 are affected.  Versions before PostgreSQL 18 are unaffected.

Weakness: CWE-126 (Buffer Over-read)

## Which versions are affected by CVE-2026-6575?

1 open source package ship an affected version, including postgresql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | From 18.0.0 | 18.4.0 |

Products: Postgresql Postgresql.

## How do I fix CVE-2026-6575?

Upgrade postgresql to 18.4.0 or later.

## Is CVE-2026-6575 being exploited?

There is no known exploitation of CVE-2026-6575 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-6575 and fix it if it is affected.

What it is: CVE-2026-6575 is a medium-severity vulnerability in Postgresql Postgresql, published on 14 May 2026. 
Exploitation: There is no known exploitation of CVE-2026-6575 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected from 18.0.0; fixed in 18.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-6575/ (Markdown: https://insights.sbomify.com/CVE-2026-6575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-6575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-6575
- OSV: https://osv.dev/vulnerability/CVE-2026-6575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-6575/
Summaries are generated and may contain mistakes; the official description above is the record.
