# CVE-2026-65828: Zammad: Pending upload deletion bypass via legacy attachment endpoint

> An authenticated attacker can delete other users' pending file uploads by exploiting a missing ownership check in the legacy attachment endpoint.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-x4f3-367g-m93g

## What is CVE-2026-65828?

CVE-2026-65828 is a low-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Zammad is a web based open source helpdesk/customer support system. Prior to 7.1.2, the legacy destroy_form action on AttachmentsController deletes UploadCache Store records based solely on a user-supplied form_id without verifying that the requesting user owns those records. An authenticated attacker who learns another user's pending-upload UUID can silently remove temporary file uploads before the victim submits their ticket or article. This issue is fixed in version 7.1.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-65828?


## How do I fix CVE-2026-65828?

No fix has been published for CVE-2026-65828 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-65828 being exploited?

There is no known exploitation of CVE-2026-65828 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65828 and fix it if it is affected.

What it is: CVE-2026-65828 is a low-severity missing authorization vulnerability in zammad, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65828 in the wild and no public exploit code.

Affected product: zammad. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65828/ (Markdown: https://insights.sbomify.com/CVE-2026-65828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65828
- OSV: https://osv.dev/vulnerability/CVE-2026-65828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65828/
Summaries are generated and may contain mistakes; the official description above is the record.
