# CVE-2026-65829: MPXJ: Potential Path Traversal Vulnerability in Primavera P3 PRX and SureTrak STX readers

> Attackers can write files to arbitrary filesystem locations by tricking users into opening malicious Primavera or SureTrak project files with the MPXJ library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** GHSA-7952-gx68-cjqr, PYSEC-2026-4108

## What is CVE-2026-65829?

CVE-2026-65829 is a medium-severity path traversal vulnerability in joniles mpxj, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MPXJ is an open source library to read and write project plans from a variety of file formats and databases. From 7.3.0 until 16.5.0, reading a suitably crafted Primavera P3 PRX or SureTrak STX file can cause MPXJ to write files to arbitrary locations in the filesystem. This issue is fixed in version 16.5.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-65829?

15 open source packages ship an affected version, including mpxj, net.sf.mpxj:mpxj and MPXJ.Net.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mpxj` | PyPI | From 7.3.0 | 16.5.0 |
| `mpxj` | PyPI | From 7.3.0 | 16.5.0 |
| `mpxj` | PyPI | From 7.3.0 | 16.5.0 |
| `mpxj` | RubyGems | From 7.3.0 | 16.5.0 |
| `mpxj` | RubyGems | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj:mpxj` | Maven | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj:mpxj` | Maven | From 7.3.0 | 16.5.0 |
| `MPXJ.Net` | NuGet | From 7.3.0 | 16.5.0 |
| `MPXJ.Net` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj-for-csharp` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj-for-csharp` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj-for-vb` | NuGet | From 7.3.0 | 16.5.0 |
| `net.sf.mpxj-for-vb` | NuGet | From 7.3.0 | 16.5.0 |

## How do I fix CVE-2026-65829?

Upgrade mpxj to 16.5.0 or later.

## Is CVE-2026-65829 being exploited?

There is no known exploitation of CVE-2026-65829 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65829 and fix it if it is affected.

What it is: CVE-2026-65829 is a medium-severity path traversal vulnerability in joniles mpxj, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65829 in the wild and no public exploit code.

Affected packages and fixed versions:
- mpxj (PyPI): affected from 7.3.0; fixed in 16.5.0
- mpxj (PyPI): affected from 7.3.0; fixed in 16.5.0
- mpxj (PyPI): affected from 7.3.0; fixed in 16.5.0
- mpxj (RubyGems): affected from 7.3.0; fixed in 16.5.0
- mpxj (RubyGems): affected from 7.3.0; fixed in 16.5.0
- net.sf.mpxj:mpxj (Maven): affected from 7.3.0; fixed in 16.5.0
- net.sf.mpxj:mpxj (Maven): affected from 7.3.0; fixed in 16.5.0
- MPXJ.Net (NuGet): affected from 7.3.0; fixed in 16.5.0
- MPXJ.Net (NuGet): affected from 7.3.0; fixed in 16.5.0
- net.sf.mpxj (NuGet): affected from 7.3.0; fixed in 16.5.0
- net.sf.mpxj (NuGet): affected from 7.3.0; fixed in 16.5.0
- net.sf.mpxj-for-csharp (NuGet): affected from 7.3.0; fixed in 16.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65829/ (Markdown: https://insights.sbomify.com/CVE-2026-65829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65829
- OSV: https://osv.dev/vulnerability/CVE-2026-65829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65829/
Summaries are generated and may contain mistakes; the official description above is the record.
