{"answers":{"affected":"2 open source packages ship an affected version, including com.arcadedb:arcadedb-server.","exploited":"There is no known exploitation of CVE-2026-65831 in the wild and no public exploit code.","fix":"Upgrade com.arcadedb:arcadedb-server to 26.7.1 or later.","what":"CVE-2026-65831 is a high-severity vulnerability in ArcadeData arcadedb, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-65831 and fix it if it is affected.\n\nWhat it is: CVE-2026-65831 is a high-severity vulnerability in ArcadeData arcadedb, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-65831 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.arcadedb:arcadedb-server (Maven): affected all versions; fixed in 26.7.1\n- com.arcadedb:arcadedb-server (Maven): affected all versions; fixed in 26.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65831/ (Markdown: https://insights.sbomify.com/CVE-2026-65831/index.md)","id":"CVE-2026-65831","markdown":"https://insights.sbomify.com/CVE-2026-65831/index.md","name":"CVE-2026-65831","record":{"aliases":["GHSA-48qw-824m-86pr"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"ArcadeDB database","requires_auth":"low_privilege","summary":"A read-only user can escalate privileges to read arbitrary host files via JavaScript injection in the command API.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"ArcadeDB is a Multi-Model DBMS. Prior to 26.7.1, a reader-role user can submit POST /api/v1/command/{database} with language: js because PolyglotQueryEngine.command, PolyglotQueryEngine.analyze, and PolyglotQueryEngine.registerFunctions do not enforce database-administrator authorization. GraalPolyglotEngine also permits scripts to bypass the allowedPackages whitelist by reflecting from the bound database object through database.getClass().getClassLoader().loadClass to arbitrary host classes. These cooperating defects allow a read-only database user to read arbitrary host files outside the database scope. Process creation is already blocked, so OS command execution is not confirmed. The issue is distinct from CVE-2026-44221, CVE-2026-54076, and CVE-2026-54077. This issue is fixed in version 26.7.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"ArcadeDB: Privilege escalation via reader role in /api/v1/command JS scripting language — arbitrary host file read","id":"CVE-2026-65831","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Memory corruption in deskflow","id":"CVE-2026-65832"},"packages":[{"ecosystem":"Maven","fixed":["26.7.1"],"introduced":["0"],"last_affected":[],"package":"com.arcadedb:arcadedb-server","purl":null,"source":"GHSA-48qw-824m-86pr"},{"ecosystem":"Maven","fixed":["26.7.1"],"introduced":["0"],"last_affected":[],"package":"com.arcadedb:arcadedb-server","purl":"pkg:maven/com.arcadedb/arcadedb-server","source":"GHSA-48qw-824m-86pr"}],"prev":{"headline":"MPXJ: Potential Path Traversal Vulnerability in Primavera P3 PRX and SureTrak STX readers","id":"CVE-2026-65829"},"products":["arcadedb","arcadedb-server"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["ArcadeData","com.arcadedb"]},"summary":"A read-only user can escalate privileges to read arbitrary host files via JavaScript injection in the command API.","url":"https://insights.sbomify.com/CVE-2026-65831/"}