CVE-2026-65948 Apache Ranger: UnixAuth lacks brute-force protection

High 7.3 Published Updated

Attackers can brute-force credentials in Apache Ranger's UnixAuth module due to missing rate limiting, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-65948?

CVE-2026-65948 is a high-severity vulnerability in Apache Ranger, published on 10 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

UnixAuth lacks brute-force protection in Apache Ranger versions <= 2.8.0.  Note:  UnixAuth is NOT a recommended option for production deployments.  Users are recommended to upgrade to version 2.9.0, which fixes this issue.

Weakness: CWE-307

Which versions are affected by CVE-2026-65948?

It affects 1 product.

Products include Apache Ranger.

How do I fix CVE-2026-65948?

No fix has been published for CVE-2026-65948 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-65948 being exploited?

There is no known exploitation of CVE-2026-65948 in the wild and no public exploit code.

Sources

Also known as GHSA-vx4h-hjjm-mwrc.

Is CVE-2026-65948 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free