{"answers":{"affected":"2 open source packages ship an affected version, including phpcsstandards/phpcsutils.","exploited":"There is no known exploitation of CVE-2026-65954 in the wild and no public exploit code.","fix":"Upgrade phpcsstandards/phpcsutils to 1.2.3 or later.","what":"CVE-2026-65954 is a high-severity code injection vulnerability in PHPCSStandards PHPCSUtils, published on 12 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-65954 and fix it if it is affected.\n\nWhat it is: CVE-2026-65954 is a high-severity code injection vulnerability in PHPCSStandards PHPCSUtils, published on 12 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-65954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpcsstandards/phpcsutils (Packagist): affected from 1.0.0-alpha1; fixed in 1.2.3\n- phpcsstandards/phpcsutils (Packagist): affected from 1.0.0-alpha1; fixed in 1.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-65954/ (Markdown: https://insights.sbomify.com/CVE-2026-65954/index.md)","id":"CVE-2026-65954","markdown":"https://insights.sbomify.com/CVE-2026-65954/index.md","name":"CVE-2026-65954","record":{"aliases":["GHSA-r6hr-vr92-vv28"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP code analysis library","requires_auth":"none","summary":"Attackers can execute arbitrary code on the scanning host by providing malicious array keys in PHP code analyzed by PHPCSUtils.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"PHPCSUtils is a suite of utility functions for use with PHP_CodeSniffer. From 1.0.0-alpha1 until 1.2.3, PHPCSUtils\\AbstractSniffs\\AbstractArrayDeclarationSniff::getActualArrayKey() evaluates attacker-controlled array-key expressions with eval(), allowing callback-form keys in untrusted PHP code scanned by an extending sniff to execute arbitrary commands on the scanning host. Known reachable paths include Universal.Arrays.DuplicateArrayKey and Universal.Arrays.MixedArrayKeyTypes. This issue is fixed in version 1.2.3.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHPCSUtils: Remote code execution via eval() in AbstractArrayDeclarationSniff::getActualArrayKey()","id":"CVE-2026-65954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"KubePi: Unauthenticated SSO/OIDC configuration allows admin account takeover and SSRF","id":"CVE-2026-65956"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.3"],"introduced":["1.0.0-alpha1"],"last_affected":[],"package":"phpcsstandards/phpcsutils","purl":null,"source":"GHSA-r6hr-vr92-vv28"},{"ecosystem":"Packagist","fixed":["1.2.3"],"introduced":["1.0.0-alpha1"],"last_affected":[],"package":"phpcsstandards/phpcsutils","purl":"pkg:composer/phpcsstandards/phpcsutils","source":"GHSA-r6hr-vr92-vv28"}],"prev":{"headline":"Apache Ranger: UnixAuth lacks brute-force protection","id":"CVE-2026-65948"},"products":["PHPCSUtils"],"published":"2026-10-12","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-13","vendors":["PHPCSStandards"]},"summary":"Attackers can execute arbitrary code on the scanning host by providing malicious array keys in PHP code analyzed by PHPCSUtils.","url":"https://insights.sbomify.com/CVE-2026-65954/"}