# CVE-2026-65954: PHPCSUtils: Remote code execution via eval() in AbstractArrayDeclarationSniff::getActualArrayKey()

> Attackers can execute arbitrary code on the scanning host by providing malicious array keys in PHP code analyzed by PHPCSUtils.

- **Severity:** High 8.6 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Oct 2026
- **Updated:** 13 Oct 2026
- **Also known as:** GHSA-r6hr-vr92-vv28

## What is CVE-2026-65954?

CVE-2026-65954 is a high-severity code injection vulnerability in PHPCSStandards PHPCSUtils, published on 12 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PHPCSUtils is a suite of utility functions for use with PHP_CodeSniffer. From 1.0.0-alpha1 until 1.2.3, PHPCSUtils\AbstractSniffs\AbstractArrayDeclarationSniff::getActualArrayKey() evaluates attacker-controlled array-key expressions with eval(), allowing callback-form keys in untrusted PHP code scanned by an extending sniff to execute arbitrary commands on the scanning host. Known reachable paths include Universal.Arrays.DuplicateArrayKey and Universal.Arrays.MixedArrayKeyTypes. This issue is fixed in version 1.2.3.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-65954?

2 open source packages ship an affected version, including phpcsstandards/phpcsutils.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpcsstandards/phpcsutils` | Packagist | From 1.0.0-alpha1 | 1.2.3 |
| `phpcsstandards/phpcsutils` | Packagist | From 1.0.0-alpha1 | 1.2.3 |

## How do I fix CVE-2026-65954?

Upgrade phpcsstandards/phpcsutils to 1.2.3 or later.

## Is CVE-2026-65954 being exploited?

There is no known exploitation of CVE-2026-65954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65954 and fix it if it is affected.

What it is: CVE-2026-65954 is a high-severity code injection vulnerability in PHPCSStandards PHPCSUtils, published on 12 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-65954 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpcsstandards/phpcsutils (Packagist): affected from 1.0.0-alpha1; fixed in 1.2.3
- phpcsstandards/phpcsutils (Packagist): affected from 1.0.0-alpha1; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65954/ (Markdown: https://insights.sbomify.com/CVE-2026-65954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65954
- OSV: https://osv.dev/vulnerability/CVE-2026-65954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65954/
Summaries are generated and may contain mistakes; the official description above is the record.
