{"answers":{"affected":"3 open source packages ship an affected version, including langflow-base.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6596 exists.","fix":"Upgrade langflow-base to 0.9.1 or later.","what":"CVE-2026-6596 is a medium-severity vulnerability in langflow-ai langflow, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6596 and fix it if it is affected.\n\nWhat it is: CVE-2026-6596 is a medium-severity vulnerability in langflow-ai langflow, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6596 exists.\n\nAffected packages and fixed versions:\n- langflow-base (PyPI): affected all versions; fixed in 0.9.1\n- langflow-base (PyPI): affected all versions; fixed in 0.9.1\n- langflow-base (PyPI): affected all versions; fixed in 0.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6596/ (Markdown: https://insights.sbomify.com/CVE-2026-6596/index.md)","id":"CVE-2026-6596","markdown":"https://insights.sbomify.com/CVE-2026-6596/index.md","name":"CVE-2026-6596","record":{"aliases":["ECHO-1ad9-0756-42bd","GHSA-vvfc-fp59-m92g","PYSEC-2026-2572"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Langflow AI platform","requires_auth":"none","summary":"Attackers can upload malicious files via the API endpoint, potentially leading to code execution or privilege escalation in Langflow.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"A security flaw has been discovered in langflow-ai langflow up to 1.1.0. This issue affects the function create_upload_file of the file src/backend/base/Langflow/api/v1/endpoints.py of the component API Endpoint. The manipulation results in unrestricted upload. It is possible to launch the attack remotely. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"langflow-ai langflow API Endpoint endpoints.py create_upload_file unrestricted upload","id":"CVE-2026-6596","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"file_upload","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"langflow-ai langflow Flow Using API core.py has_api_terms credentials storage","id":"CVE-2026-6597"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow-base","purl":null,"source":"GHSA-vvfc-fp59-m92g"},{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow-base","purl":"pkg:pypi/langflow-base","source":"GHSA-vvfc-fp59-m92g"},{"ecosystem":"PyPI","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow-base","purl":"pkg:pypi/langflow-base","source":"PYSEC-2026-2572"}],"prev":{"headline":"ProjectsAndPrograms School Management System HTTP GET Parameter buslocation.php sql injection","id":"CVE-2026-6595"},"products":["langflow"],"published":"2026-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["langflow-ai"]},"summary":"Attackers can upload malicious files via the API endpoint, potentially leading to code execution or privilege escalation in Langflow.","url":"https://insights.sbomify.com/CVE-2026-6596/"}