# CVE-2026-65979: OpenEXR: Out-of-bounds read in HTJ2K decoder from unvalidated chunk header length (PLEN)

> An attacker can cause an out-of-bounds read in the OpenEXR HTJ2K decoder by providing a crafted image file, leading to potential crashes or data exposure.

- **Severity:** Medium 6.7 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BELL-CVE-2026-65979, DEBIAN-CVE-2026-65979, GHSA-3j9c-j7c9-x293, MINI-q3x4-vw4v-7xj6, UBUNTU-CVE-2026-65979

## What is CVE-2026-65979?

CVE-2026-65979 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. From version 3.4.0 through 3.4.12, the HTJ2K decoder parses a header-length field (PLEN) from a chunk's compressed data but never checks that this value fits within the available buffer before using it. When decoding, it advances the codestream pointer by the attacker-supplied header size and passes the resulting offset and remaining length to the OpenJPH memory-input path, so a crafted value pushes the pointer past the end of the buffer and causes an out-of-bounds read. Because this field comes straight from attacker-controlled EXR chunk data, the flaw is reachable during normal decoding of an untrusted file. This issue is fixed in version 3.4.13.

Weakness: CWE-20 (Improper Input Validation), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-65979?


## How do I fix CVE-2026-65979?

Upgrade to a fixed version.

## Is CVE-2026-65979 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65979 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65979 and fix it if it is affected.

What it is: CVE-2026-65979 is a medium-severity memory corruption vulnerability in AcademySoftwareFoundation openexr, published on 25 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-65979 exists.

Affected product: AcademySoftwareFoundation openexr. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65979/ (Markdown: https://insights.sbomify.com/CVE-2026-65979/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65979
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65979
- OSV: https://osv.dev/vulnerability/CVE-2026-65979

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65979/
Summaries are generated and may contain mistakes; the official description above is the record.
