{"answers":{"affected":"3 open source packages ship an affected version, including langflow.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6598 exists.","fix":"Upgrade langflow to 1.9.1 or later.","what":"CVE-2026-6598 is a medium-severity vulnerability in langflow-ai langflow, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-6598 and fix it if it is affected.\n\nWhat it is: CVE-2026-6598 is a medium-severity vulnerability in langflow-ai langflow, published on 20 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-6598 exists.\n\nAffected packages and fixed versions:\n- langflow (PyPI): affected all versions; fixed in 1.9.1\n- langflow (PyPI): affected all versions; fixed in 1.9.1\n- langflow (PyPI): affected all versions; fixed in 1.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-6598/ (Markdown: https://insights.sbomify.com/CVE-2026-6598/index.md)","id":"CVE-2026-6598","markdown":"https://insights.sbomify.com/CVE-2026-6598/index.md","name":"CVE-2026-6598","record":{"aliases":["GHSA-9jpj-cph8-w449","PYSEC-2026-2568"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Langflow AI platform","requires_auth":"low_privilege","summary":"Attackers can read sensitive authentication settings stored in cleartext on disk due to improper encryption in the project creation endpoint.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-313","name":"Cleartext Storage in a File or on Disk"},{"id":"CWE-312","name":"Cleartext Storage of Sensitive Information"}],"description":"A security vulnerability has been detected in langflow-ai langflow up to 1.8.3. The affected element is the function create_project/encrypt_auth_settings of the file src/backend/base/Langflow/api/v1/projects.py of the component Project Creation Endpoint. Such manipulation of the argument auth_settings leads to cleartext storage in a file or on disk. The attack can be launched remotely. The exploit has been disclosed publicly and may be used. The vendor was contacted early about this disclosure but did not respond in any way.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"langflow-ai langflow Project Creation Endpoint projects.py encrypt_auth_settings cleartext storage in file","id":"CVE-2026-6598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"langflow-ai langflow Model Context Protocol Configuration API mcp_projects.py install_mcp_config injection","id":"CVE-2026-6599"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow","purl":null,"source":"GHSA-9jpj-cph8-w449"},{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"GHSA-9jpj-cph8-w449"},{"ecosystem":"PyPI","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"langflow","purl":"pkg:pypi/langflow","source":"PYSEC-2026-2568"}],"prev":{"headline":"langflow-ai langflow Flow Using API core.py has_api_terms credentials storage","id":"CVE-2026-6597"},"products":["langflow"],"published":"2026-04-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-20","vendors":["langflow-ai"]},"summary":"Attackers can read sensitive authentication settings stored in cleartext on disk due to improper encryption in the project creation endpoint.","url":"https://insights.sbomify.com/CVE-2026-6598/"}