# CVE-2026-65984: FUXA: JWT lifecycle flaws allow deleted or demoted users to retain privileged sessions

> Attackers with valid tokens can retain privileged access after account deletion or demotion due to flawed JWT refresh logic in FUXA.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-rg7m-xwqc-mjw6

## What is CVE-2026-65984?

CVE-2026-65984 is a high-severity authentication bypass vulnerability in frangoteam FUXA, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. In 1.3.2 and earlier, POST /api/refresh in server/api/auth/index.js falls back from current user data to decoded.groups, including when the user is deleted or groups is zero, and POST /api/heartbeat in server/api/index.js re-signs inbound JWT claims without validating the current database record. An attacker who possesses a previously issued privileged refresh cookie or access token can continue minting privileged JWTs after account deletion, disablement, role removal, or demotion. Continued refresh-cookie rotation can extend the stale session and preserve unauthorized access to user management, project manipulation, runtime configuration, scripts, and backdoor-account creation. This issue is fixed in version 1.3.3.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-65984?


## How do I fix CVE-2026-65984?

No fix has been published for CVE-2026-65984 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-65984 being exploited?

There is no known exploitation of CVE-2026-65984 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-65984 and fix it if it is affected.

What it is: CVE-2026-65984 is a high-severity authentication bypass vulnerability in frangoteam FUXA, published on 18 Aug 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-65984 in the wild and no public exploit code.

Affected product: frangoteam FUXA. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-65984/ (Markdown: https://insights.sbomify.com/CVE-2026-65984/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-65984
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-65984
- OSV: https://osv.dev/vulnerability/CVE-2026-65984

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-65984/
Summaries are generated and may contain mistakes; the official description above is the record.
