# CVE-2026-66001: Frappe: Improper Authorization in OAuth2 Consent Endpoint

> Attackers can trick authenticated users into approving OAuth grants or reusing authorization state, exposing data and permitting unauthorized actions.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-2ph8-x773-8p2x

## What is CVE-2026-66001?

CVE-2026-66001 is a high-severity vulnerability in frappe, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Frappe is a full-stack web application framework. Prior to 15.114.0 and 16.26.0, the approve and authorize functions in frappe/integrations/oauth2.py allow the OAuth2 consent flow to proceed without restricting approve to POST, without a csrf_token in frappe/templates/includes/oauth_confirmation.html, and without scoping an active OAuth token check to the requesting client. An attacker can cause an authenticated user to approve an OAuth grant or reuse authorization state for the wrong client, exposing data and permitting actions within the granted scopes. This issue is fixed in versions 15.114.0 and 16.26.0.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-66001?


## How do I fix CVE-2026-66001?

No fix has been published for CVE-2026-66001 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-66001 being exploited?

There is no known exploitation of CVE-2026-66001 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66001 and fix it if it is affected.

What it is: CVE-2026-66001 is a high-severity vulnerability in frappe, published on 20 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-66001 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66001/ (Markdown: https://insights.sbomify.com/CVE-2026-66001/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66001
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66001
- OSV: https://osv.dev/vulnerability/CVE-2026-66001

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66001/
Summaries are generated and may contain mistakes; the official description above is the record.
