# CVE-2026-66003: Frappe: Access control bypass via REST API dot-notation fields on linked doctypes

> Low-privileged users can bypass access controls to read unauthorized data from linked records via the REST API in the Frappe framework.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Aug 2026
- **Updated:** 27 Aug 2026
- **Also known as:** GHSA-p25m-7rvg-6fvr

## What is CVE-2026-66003?

CVE-2026-66003 is a high-severity missing authorization vulnerability in frappe, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework written in Python and JavaScript. Prior to version 15.115.0, an access control bypass in the REST API allows a user to read data from Linked DocTypes that they are not authorized to access. When a document references another document through a Link field, the framework does not consistently enforce the linked DocType's own permissions when the record is retrieved through the REST API, so a low-privileged authenticated user can obtain fields from linked records outside their permitted scope. This issue is fixed in version 15.115.0.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-66003?


## How do I fix CVE-2026-66003?

No fix has been published for CVE-2026-66003 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-66003 being exploited?

There is no known exploitation of CVE-2026-66003 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66003 and fix it if it is affected.

What it is: CVE-2026-66003 is a high-severity missing authorization vulnerability in frappe, published on 26 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-66003 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66003/ (Markdown: https://insights.sbomify.com/CVE-2026-66003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66003
- OSV: https://osv.dev/vulnerability/CVE-2026-66003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66003/
Summaries are generated and may contain mistakes; the official description above is the record.
