{"answers":{"affected":"3 open source packages ship an affected version, including blender-mcp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66004 exists.","fix":"Upgrade blender-mcp to 1.6.5 or later.","what":"CVE-2026-66004 is a medium-severity path traversal vulnerability in ahujasid blender-mcp, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-66004 and fix it if it is affected.\n\nWhat it is: CVE-2026-66004 is a medium-severity path traversal vulnerability in ahujasid blender-mcp, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66004 exists.\n\nAffected packages and fixed versions:\n- blender-mcp (PyPI): affected all versions; fixed in 1.6.5\n- blender-mcp (PyPI): affected all versions; fixed in 1.6.5\n- blender-mcp (PyPI): affected all versions; fixed in 1.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-66004/ (Markdown: https://insights.sbomify.com/CVE-2026-66004/index.md)","id":"CVE-2026-66004","markdown":"https://insights.sbomify.com/CVE-2026-66004/index.md","name":"CVE-2026-66004","record":{"aliases":["GHSA-4h8q-hh2j-755w","PYSEC-2026-4203"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Blender MCP library","requires_auth":"none","summary":"Attackers can write arbitrary files via path traversal in the download_polyhaven_asset API, potentially achieving persistent code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"BlenderMCP before commit 30a3308 contains a path traversal vulnerability in the download_polyhaven_asset method that allows attackers to write arbitrary files by injecting traversal sequences in API response include keys. Attackers performing MITM attacks or prompt injection can supply malicious paths like '../../.bashrc' to overwrite sensitive files and achieve persistent code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"BlenderMCP Path Traversal via download_polyhaven_asset API","id":"CVE-2026-66004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"Jan Local API Server CORS Origin Reflection via 0.0.0.0 Binding","id":"CVE-2026-66005"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.5"],"introduced":["0"],"last_affected":[],"package":"blender-mcp","purl":null,"source":"GHSA-4h8q-hh2j-755w"},{"ecosystem":"PyPI","fixed":["1.6.5"],"introduced":["0"],"last_affected":[],"package":"blender-mcp","purl":"pkg:pypi/blender-mcp","source":"GHSA-4h8q-hh2j-755w"},{"ecosystem":"PyPI","fixed":["1.6.5"],"introduced":["0"],"last_affected":[],"package":"blender-mcp","purl":"pkg:pypi/blender-mcp","source":"PYSEC-2026-4203"}],"prev":{"headline":"Frappe: Access control bypass via REST API dot-notation fields on linked doctypes","id":"CVE-2026-66003"},"products":["blender-mcp"],"published":"2026-07-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-27","vendors":["ahujasid"]},"summary":"Attackers can write arbitrary files via path traversal in the download_polyhaven_asset API, potentially achieving persistent code execution.","url":"https://insights.sbomify.com/CVE-2026-66004/"}