# CVE-2026-66004: BlenderMCP Path Traversal via download_polyhaven_asset API

> Attackers can write arbitrary files via path traversal in the download_polyhaven_asset API, potentially achieving persistent code execution.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** GHSA-4h8q-hh2j-755w, PYSEC-2026-4203

## What is CVE-2026-66004?

CVE-2026-66004 is a medium-severity path traversal vulnerability in ahujasid blender-mcp, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

BlenderMCP before commit 30a3308 contains a path traversal vulnerability in the download_polyhaven_asset method that allows attackers to write arbitrary files by injecting traversal sequences in API response include keys. Attackers performing MITM attacks or prompt injection can supply malicious paths like '../../.bashrc' to overwrite sensitive files and achieve persistent code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-66004?

3 open source packages ship an affected version, including blender-mcp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blender-mcp` | PyPI | All versions | 1.6.5 |
| `blender-mcp` | PyPI | All versions | 1.6.5 |
| `blender-mcp` | PyPI | All versions | 1.6.5 |

## How do I fix CVE-2026-66004?

Upgrade blender-mcp to 1.6.5 or later.

## Is CVE-2026-66004 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66004 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-66004 and fix it if it is affected.

What it is: CVE-2026-66004 is a medium-severity path traversal vulnerability in ahujasid blender-mcp, published on 24 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-66004 exists.

Affected packages and fixed versions:
- blender-mcp (PyPI): affected all versions; fixed in 1.6.5
- blender-mcp (PyPI): affected all versions; fixed in 1.6.5
- blender-mcp (PyPI): affected all versions; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-66004/ (Markdown: https://insights.sbomify.com/CVE-2026-66004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-66004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-66004
- OSV: https://osv.dev/vulnerability/CVE-2026-66004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-66004/
Summaries are generated and may contain mistakes; the official description above is the record.
